Hello,
I am trying to access PT4 but I keep getting the error:
"Unable to connect to this database. Please check the configuration."
I have tried some of the troubleshooting options listed below:
Problems
Unable to Login to the Database
If you get an error message which looks like this:
unable to login to database (PT4_xxxx_xx_xx_xxxxxx) - reason:could not connect to server:connection refused(0x0000274D/10061) Is the server running on host "localhost" and accepting TCPT/IP connection on port 5432?
The first thing to try is to restart the PostgreSQL service. The simplest way to accomplish this is by restarting your computer. Some Windows users can also try stopping the service manually by selecting Start -> Programs -> PostgreSQL -> Stop Service, but this option is not always available If you are able to stop the PostgreSQL service using this method, you can attempt to search your computer for the postmaster.pid file in /Program Files/PostgreSQL/X.X/data, if this file is found you can safely delete it then restart your computer. This will often, but not always solve the problem. Do not attempt to delete the postmaster.pid file unless the PostgreSQL service has stopped.
Replace X.X with the PostgreSQL version number, this is usually 8.3, 8.4, or 9.0.
If you get an error message which looks like this:
unable to login to database (PT4 DB). Reason: FATAL: no pg_hba.conf entry for host "::1", user "postgres", database "PT4 DB", SSL off
Edit the pg_hba.conf file.
Windows:
You must use a text editor while acting as an administrator when editing the pg_hba.conf file. To accomplish this task, we suggest you run Notepad by right clicking on the icon, then select Run As Administrator. Click File > Open, then select the pg_hba.conf file which is normally found at C:/Programs Files/PostgreSQL/X.X/data/pg_hba.conf.
Scroll to the bottom, and add this line exactly as you see it here:
host all all ::1/128 md5
Save the file and quit NotePad. To enable the changes you must either restart your computer or click Start > Programs > PostgreSQL > Reload Configuration.
Mac OS X:
Run the Terminal application found at /Applications/Utilities/Terminal.
Type sudo nano /Library/PostgreSQL/X.X/data/pg_hba.conf. Type in your OS X administrator password if requested. This will start the Nano text editor inside of the Terminal window.
Use the down arrow key to scroll to the bottom of the file, and add this line exactly as you see it here: host all all ::1/128 md5
Click CTRL+O to save the file, then CTRL+X to exit the text editor.
Restart your computer to enable the changes.
Replace X.X with the PostgreSQL version number, this is usually 8.3, 8.4, or 9.0
However my terminal could not find the postmaster.pid file and after I did the other "host all all ::1/128 md5" following the instructions and restarted my mac I could still not get past the same error.
Could you please help?
Thank you,
Christian
